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About This Book
This guide provides a detailed description of how to use the Freescale IEEE® 802.15.4/Zigbee™ 
Evaluation Kit (13193EVK), part number 13193EVK-A00.

The 13193EVK provides a flexible demonstration and development environment for the Freescale ZigBee 
family of products.  In addition to the hardware, the kit provides utilities and sample applications that 
demonstrate functionality from simple proprietary applications, 802.15.4 applications, all the way to full 
ZigBee compatible solutions.

Refer to the Freescale BeeKit Wireless Connectivity Toolkit User’s Guide (BKWCTKUG) for complete 
software installation details.

Audience
This document is intended for application developers. 

Organization
This document is organized into 6 chapters.

Chapter 1 Safety Information - This chapter provides operating guidelines for the 
13193EVK.

Chapter 2 13192-EVB Board Overview - This chapter describes the 13192-EVB evaluation 
boards and system components that ship with the 13193EVK.

Chapter 3 Embedded Bootloader Ultility and Programming - This chapter describes the 
Test Tool Utility’s Embedded Bootloader application.

Chapter 4 Evaluation Kit Demonstration Applications - This chapter lists the various 
demonstration applications.

Chapter 5 Solution Development - This chapter shows users how to begin development of 
an MC13192 system solution. 

Chapter 6 Test Tool Utility - This chapter shows users how to use the Test Tool utility. 

Revision History
The following table summarizes revisions to this document since the previous release (Rev 1.0).

Revision History

Location Revision

Entire Document Updated for BeeKit
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Conventions
This document uses the following notational conventions:

• Courier monospaced type indicate commands, command parameters, code examples, expressions, 
datatypes, and directives.

• Italic type indicates replaceable command parameters.

• All source code examples are in C.

Definitions, Acronyms, and Abbreviations
The following list defines the  acronyms and abbreviations used in this document.

BDM debugger A debugger using the BDM interface for communication with the MCU. An 
example is the P&E BDM Multilink debugger for HCS08.

BDM Background Debug Module

13193EVK The 802.15.4/Zigbee Evaluation Kit

GUI Graphical User Interface

MAC Medium Access Control

MCU MicroController Unit

NVM None-Volatile Memory

PC Personal Computer

PCB Printed Circuit Board

S19 'S19' is the file extension used for the Freescale binary image format. The S19 file 
encapsulates the binary image as a list of ASCII records. Each record contains a 
length -, address -, data - and checksum field. The 16 bit address field allows a 
memory space for up to 64 KB. The S19 can be generated with Metroworks 
Codewarrior IDE and is the product from the linking process. S19 does not contain 
additional information to a debugger (where to look for source files).

Safe Mode Boot The Embedded Bootloader boots up using safe default system values.

HIWAVE P&E HCS08 debugger GUI.

CPROG P&E HCS08 flash programming tool called from HIWAVE. The tool is also 
available in a command line version where scripts can be made.
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Chapter 1   
Safety Information
Any modifications to this product may violate the rules of the Federal Communications Commission and 
make operation of the product unlawful.

47 C.F.R. Sec. 15.21

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant 
to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful 
interference in a residential installation. This equipment generates, uses and can radiate radio frequency 
energy and, if not installed and used in accordance with the instructions, may cause harmful interference 
to radio communications. However, there is no guarantee that interference will not occur in a particular 
installation.  If this equipment does cause harmful interference to radio or television reception, which can 
be determined by turning the equipment off and on, the user is encouraged to try to correct the interference 
by one or more of the following measures:

• Reorient or relocate the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from that to which the receiver is 
connected.

• Consult the dealer or an experienced radio/TV technician for help.

47 C.F.R. Sec.15.105(b)

This equipment complies with FCC radiation exposure limits set forth for an uncontrolled environment. 
The antenna(s) used for this equipment must be installed to provide a separation distance of at least 8 
inches (20cm) from all persons.

This device complies with Part 15 of the FCC Rules.  Operation is subject to the following two conditions:

1. This device may not cause harmful interference.

2. This device must accept any interference received, including interference that may cause undesired 
operation.

3. This device is susceptible to electrostatic discharge (ESD) and surge phenomenon. 
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Chapter 2   
13193EVK Board Overview
The 13193EVK contains two different types of boards.

1. 13192-EVB

2. 13192-SARD

These boards include the following on-board components except where noted otherwise:

• MC13192, 2.4GHz transceiver

• MC9S08GT60 Micro Controller Unit (MCU)

• MMA6261Q accelerometer (13192-SARD only)

• MMA1260D accelerometer (13192-SARD only)

2.1 13193EVK Components
The boards shipped with the 13193EVK are delivered with pre-loaded demonstration applications.  More 
applications can be uploaded with either the Embedded Bootloader utility which is located in the Freescale 
Test Tool application, or with CodeWarrior using the USB Multilink programmer (provided).  The 
CodeWarrior CD ROM (provided) requires users to register for a 30-day evaluation key.  After this time, 
users must purchase a standard key to use the CodeWarrior Software (see the CodeWarrior documentation 
for detailed information).

The CodeWarrior software is not required to run the demonstrations or utilities described in this guide. The 
13193EVK contains the 13192-EVB and the 13192-SARD boards. To see a complete list of demonstration 
applications, see Chapter 4, “Evaluation Kit Demonstration Applications”

NOTE
To run ZigBee specific applications, see the appropriate Freescale BeeStack 
documentation.

2.2 13193EVK Contents
Section 2.3, “Common Board Components” lists the board hardware and additional items contained in 
the 13193EVK-A00 development kit.

Table 2-1. 13193EVK Boards

P/N Description QTY

13192-EVB 802.15.4/ZigBee Evaluation Board 3

13192-SARD 802.15.4/ZigBee Sensor Application Board 2

Power adaptor, 9Vdc with 4 interchange plugs 3
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2.3 Common Board Components

2.3.1 MC9S08GT60 MCU
The MC9S08GT60 MCU is contained on both the 13192-SARD and 13192-EVB boards.  The 
MC9S08GT60 MCU is a member of Freescale’s 8-bit, low cost, low power family of HCS08 MCUs.  It 
has 60KB of embedded flash and 4KB of RAM.  For more information, refer to the MC9S08GB60 data 
sheet at www.freescale.com/mcu.

2.3.2 MC13192 RF Data Modem
The MC13192 is contained on both the 13192-SARD and 13192-EVB boards.  The MC13192 is an 
802.15.4 compliant, ZigBee-ready transceiver.  It has a four-wire SPI interface to connect to a variety of 
microcontrollers, creating a low power, low cost solution for a range of applications. For more information 
on the MC13912, see the MC13192DS data sheet at www.freescale.com/ZigBee.

2.3.3 MMA1260D and MMA6261Q Acceleration Sensors
The MMA6261Q Acceleration Sensors are contained only on the 13192-SARD board.  The MMA1260D 
and the MMA6261Q Acceleration Sensors provide the 13192-SARD with unique applications to 

Battery, 9V 5

Cable, BDM Interface (USB), 68HCS12/68HCS08 1

Cable, 6ft.  DB9 M/F, RS-232 Serial 2

Cable, 6 ft.  USB 2.0 A-M to B-M 3

Cable, 9V Battery Clip to 2.1mm PLUG, SARD 2

Cable, 9V Battery Clip to 2.1mm RECP, EVB 3

PWA, Network Sniffer, DIG534-2 1

PWA, 13192-SARD 2

PWA, 13192-EVB 3

Hardware Documentation (BeeKit CD) 1

CD, HC(S)08 Service Pack 1

Warranty Card, Freescale, 920-75133 1

BR1530 Technical Information Center, Freescale Semiconductor, Inc 1

ZigBee Evaluation Kit User’s Guide (13193EVK) 1

Technical Summary, USB HCS08/HCS12 Multilink rev. B 1

Release Notes 13193EVK 1

Frontline Test System Setup and Quick Start Guide 1

CodeWarrior Development Studio HC(S)08 Special Edition 1

Table 2-1. 13193EVK Boards



13193EVK Board Overview

13193EVK User’s Guide, Rev. 1.1

Freescale Semiconductor 2-3
 

demonstrate wireless sensing solutions.  For more information on the MMA1260D and the MMA6261Q 
sensors, see their respective data sheets included with the 13193EVK CD or visit 
www.freescale.com/sensors.

2.4 13192-EVB Evaluation Board Description
The 13192-EVB is an 802.15.4/ZigBee evaluation board based on the MC13192, 2.4GHz transceiver and 
the MC9S08GT60 MCU.  The 13192-EVB board provides both serial and USB connectivity to a PC for 
easy evaluation.  For improved sensitivity and range evaluations, the 13192 EVB includes the necessary 
circuitry to enable the MBC13900 Low Noise Amplifier (LNA). It is also equipped with an external SMA 
connector for an external antenna connection allowing easy connectivity to a scope for test and 
measurement.  The 13192-EVB contains the following interfaces:

• 1.1 USB port

• RS232 Serial Connection

• 4 push buttons (S1, S2, S3, S4)

• 1 Reset button (Reset)

• 4 LEDs, (LED1, LED2, LED3, LED4)

• One power switch (S106)

• Printed F antenna (refer to AN2731/D for more information)

• Optional MBC13900 LNA (disabled by default, visit www.freescale.com/rf for more information)

• SMA RF connector (disabled by default)

• Background Debug Module (BDM) connection allowing flash programming and in-circuit debug 
via the included USB Multilink Cable (see the USBMULTECHSUM document included in the kit 
for more details).

• Power connector (5-9 Volts)

• 10-pin header strip for access to specific MCU and RF pins

http://www.freescale.com/rf
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Figure 2-1. 13192-EVB Block Diagram

Figure 2-2. 13192-EVB Board Layout
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NOTE
Switch S106 toggles power between the USB connector and the power 
connector.  Refer to the 13192 Evaluation Board Reference Manual, 
13192EVBRM for more info.

2.5 13192-SARD Description
The 13192-SARD is a demonstration board based on the MC13192, 2.4GHz transceiver, MC9S08GT60 
MCU, and the MMA6261Q and MMA1260D Acceleration Sensors.  The 13192-SARD contains the 
following interfaces:

• RS232 Serial Connection

• 4 push buttons (S101, S102, S103, S104)

• 1 Reset button (S106)

• 4 LEDs (D101, D102, D103, D104)

• One power switch (S105)

• Printed Dipole antenna (refer to AN2731/D for more information)

• Background Debug Module (BDM) connection allowing flash programming and in-circuit debug 
via the included USB Multilink Cable (see USBMULTECHSUM/D document included in the kit 
for more details).

• Power Connections

• Power connector (5.5-9 Volts)

• 9-Volt battery connector

• 3-Volt power connector (MMA1260D Acceleration Sensor disabled)

• 26-pin header strip (J105), for access to specific RF, MCU, and sensor pins 

Table 2-2. 13192-EVB Board Labels 

Common Name Board Designation

LED 1 LED1

LED 2 LED2

LED 3 LED3

LED 4 LED4

Button 1 S1

Button 2 S2

Button 3 S3

Button 4 S4

Reset Button Reset

Power Toggle S106
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Figure 2-3. 13192-SARD Block Diagram

Figure 2-4. 13192-SARD Board Layout
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NOTE
See the SARD User’s Guide, (MC13192SARDUG) for more information.

Table 2-3. 13192-SARD Board Labels

Common Name Board Designation

LED 1 LED D101

LED 2 LED D102

LED 3 LED D103

LED 4 LED D104

Button 1 S101

Button 2 S102

Button 3 S103

Button 4 S104

Reset Button S106

Power Switch S105
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Chapter 3   
Embedded Bootloader Utility and Programming
The 13192-SARD and 13192-EVB boards come with several pre-loaded demonstration applications. This 
chapter describes how to load additional applications included on the BeeKit CD.

See the Freescale BeeKit Wireless Connectivity ToolKit User’s Guide (BKWCTKUG) for complete 
software installation details.

There are two methods of loading application code into the 13192-SARD and 13192-EVB boards.

• Use the Freescale Test Tool Embedded Bootloader application.

• Use the supplied Background Debug Module (BDM) programmer cable and the CodeWarrior IDE.

3.1 Test Tool’s Embedded Bootloader Application
This section describes the use of the Test Tool’s Embedded Bootloader application to flash new firmware 
into the 13192-SARD and 13192-EVB boards. The Embedded Bootloader utility allows users to flash 
different application code into the boards without the use of a BDM programmer/debugger.

The Embedded Bootloader is located in a protected 4KB flash block in the highest memory area 
(0xF000-0xFFFF) of the MC9S08GT60 MCU. There is one MCU on each 13192-SARD and 13192-EVB 
boards.

NOTE
If the boards are flashed with a BDM cable, the BDM erases the Embedded 
Bootloader code and as a result, the Test Tool’s Embedded Bootloader 
utility cannot be used until the Embedded Bootloader code is re-flashed (see 
Section 3.2, “Using the BDM Programmer”)

3.1.1 Test Tool Embedded Bootloader Features
• Can upload firmware in Freescale S19 record format through the UART/USB

• Can initialize memory of upload firmware

• Can initialize the system clock frequency

• Can make run-time updates to the non-volatile memory (NVM)
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3.1.2 Flash Programming the 13192-EVB and 13192-SARD
To flash program the 13192-EVB and 13192-SARD boards, perform the following steps:

1. Connect the 13192-SARD or 13192-EVB board to an RS232 serial COM port on the PC via the 
included serial cable.

2. Connect a power source (9V battery or the 9V power supply) to the board.

3. Power on the board. If all four LEDs are not on, press and hold all four buttons simultaneously; 
S101-S104 on the 13192-SARD and S1-S4 on the 13192-EVB. Press and release the Reset Button, 
then release the four push buttons. All four LEDs should now be on. The board is now ready for 
flash programming.

NOTE
The SMAC applications call the Test Tool’s Embedded Bootloader with 
two buttons presses. The 13192-SARD use S102 and S104 while the 
13192-EVB uses S2 and S4.

4. Run the Test Tool utility from Windows by clicking on Start->Programs->Freescale Zigbee->Test 
Tool. The Test Tool main window appears as shown in Figure 3-1.

5. Setup the board connection from the Test Tool tollbar by clicking on View->Communications 
Settings, as shown in Figure 3-1.

Figure 3-1. Test Tool Window (Configuration Settings Option)

6. The List of Devices window appears as shown in Figure 3-2. Click the Add Internal button and the 
Device Settings window appears as shown in Figure 3-2.

7. In the Device Settings window, click the Serial button, choose the appropriate Com Port, and leave 
the Baudrate set to 19200.

8. Click the OK button.
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Figure 3-2. Test Tool Window (List of Devices Screen)

9. From the List of Devices window, click the Close button.

10. From the Test Tool main window toolbar, launch the Embedded Bootloader application by 
selecting View->Embedded Bootloader as shown in Figure 3-3.

Figure 3-3. Test Tool Window (Choosing Embedded Bootloader)

The Select Devices window appears as shown in Figure 3-4.

11. Choose the COM port for the device and click the OK button.
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Figure 3-4. Test Tool Window (Embedded Bootloader)

12. As shown in Figure 3-5, select the desired application for flashing from the Application Files menu 
and click the Upload button.

NOTE
• If users want to flash their own project, it must be saved as an S19 record 

and copy to the S19 directory (C:\Program Files\Freescale\Test 
Tool\s19).

• If a time-out error occurs, highlight the file and click the Upload button 
again.

Figure 3-5. Test Tool Window (Bootloader Application Select)
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A progress indicator appears in the Embedded Bootloader application window while the board is being 
flash programmed. After the board is flashed, press and release the Reset button on the board. At this point, 
the application code has been flashed into the target board and the demo is ready for use.

3.2 Using the BDM Programmer
The BDM programmer/debugger provides another method to load application code into the 13192-SARD 
and 13192-EVB boards. Read the following two documents to learn how to use the BDM 
programmer/debugger.

• The USB HCS08/HCS12 Multilink Rev B Technical Summary

• The CodeWarrior™ Development Studio for 68HC08 Quick Start Guide.

The USB HCS08/HCS12 Multilink Rev B Technical Summary describes the usage, setup, and driver 
installation details. It also provides P&E Microsystems web site for firmware updates and additional 
information.

The CodeWarrior Development Studio for 68HC08 Quick Start Guide is coupled with the CodeWarrior 
Development Studio installation CD. The Quick Start Guide describes the basic system requirements, 
software installation, license key registration and installation and additional software support.

NOTE
Flashing the boards with the BDM programmer erases all of the embedded 
flash, including the Embedded Bootloader code.

In order to re-use the Test Tool’s Embedded Bootloader utility to flash the 
boards, the Embedded Bootloader code must be reloaded via the BDM.

3.3 Installing the Embedded Bootloader Code
This section describes the installation of the Embedded Bootloader code using the P&E Multilink for 
HCS08 BDM programmer. As mentioned, two methods can be used to load application code into the 
13192-SARD and 13192-EVB boards. The use of the BDM programmer allows one to flash their 
application code into the target but as a result, erases the Embedded Bootloader code required to use the 
Test Tool’s Embedded Bootloader utility.

Users can program the Embedded Bootloader to an erased PCB or they can upgrade to a newer version of 
the Embedded Bootloader. To re-install the Embedded Bootloader code into the target, follow the 
proceedures in the next few sections.

3.3.1 Programming to an Erased Board
This section describes how to program the Embedded Bootloader to an erased board.

1. Execute the hiwave.exe file from your chosen \CodeWarrior installation directory. For example, 
[installation directory] \\CodeWarrior_CW08_Vx.x\Prog\
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2. From the main window, setup the target by selecting the Component menu, then click on Set 
Target. The Set Target window appears as shown in Figure 3-7. In the Processor drop down menu, 
select HCS08. From the Target Interface drop down menu, select P&E Target Interface, then click 
the OK button.

Figure 3-6. Set Target Window

3. When connecting for the first time, the Connection Assistant window appears prompting to select 
the debugger interface connection. As shown in Figure 3-7, a USB connection was chosen and the 
HCS08 was selected as the CPU type. Click the OK button.

Figure 3-7. Connection Wizard Window
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4. Under the File menu, click on Load Application to open the Load Executable File window as 
shown in Figure 3-8. Select Freescale S-Record (*.s19) using the Files of type: drop down menu. 
Navigate to the folder where the Embedded Bootloader.s19 file is located. Select the file and click 
the Open button.

5.

Figure 3-8. Load Executable Window

The Embedded Bootloader is now being programmed to the PCB as shown in Figure 3-9.

NOTE
In the event the status window does not appear as shown in Figure 3-9, 
select the PEDebug drop down menu, scroll down to Mode: Full Chip 
Simulation and then select In-Circuit Debug/Programming.  
Repeat Step 3 if needed.
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Figure 3-9. Status Window

6. Remove power and disconnect the BDM cable from the PCB. Next, power up the PCB. The PCB 
is now ready to upload an application. This is indicated by all four LEDs being on.

3.3.2 Upgrading The Embedded Bootloader
This section describes how to upgrade the Embedded Bootloader to a newer version with the P&E 
Multilink BDM debugger.

1. Execute the hiwave.exe file from the chosen \CodeWarrior installation directory. For example, 
[installation directory] \CodeWarrior_CW08_Vx.x\Prog\

2. From the main window, setup the target by selecting the Component menu, then click on Set 
Target. The Set Target window appears as shown in Figure 3-10. In the Processor drop down 
menu, select HCS08. From the Target Interface drop down menu, select P&E Target Interface, then 
click the OK button.
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Figure 3-10. Set Target Window

3. When connecting for the first time, the Connection Assistant window appears prompting to select 
the debugger interface connection. As shown in Figure 3-11, a USB connection was chosen and 
the HCS08 was selected as the CPU type. Click the OK button.

Figure 3-11. Connection Assistant Window

At this point, a copy of the NVM sector (both NVM0 and NVM1) with the production data must be made. 
The next few steps moves through the procedure manually by selecting a starting address and an ending 
address.

4. Select the PEDebug menu and then choose Start Expert Mode Programmer. The Programmer 
Expert window appears as shown in Figure 3-12.
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Figure 3-12. Programmer Expert Window

5. In the Programmer Expert window, double click on UR Upload Range. The Start Address window 
appears as shown in Figure 3-13. Specify the start address for the NVM section. Click the OK 
button. The following shows the start address for each NVM sector:

• For NVM0, use start address 0x152F

• For NVM1, use start address 0x172F
•

Figure 3-13. Start Address Window

6. In the End Address window, specify the end address for the NVM section and then click the OK 
button as shown in Figure 3-14. The following shows the end address for each NVM sector:

• For NVM0, use end address 0x155B
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• For NVM1, use end address 0x175B

Figure 3-14. End Address Window

7. As shown in Figure 3-15, use the S19 window to specify which S19 file to store active NVM data 
to and then click the OK button. The following shows the S19 files for each NVM sector:

• For NVM0, use PD_NVM0.s19

• For NVM1, use PD_NVM1.s19

Figure 3-15. S19 File Window

NOTE
A copy of both NVM0 and NVM1 must be made as described above before 
executing the Production_Data_Converter.exe as described in Step 9.

8. Close Programmer Expert window.

Use the PC tool Production_Data_Converter.exe to convert the production data in NVM to default NVM 
sector NVM0.

9. Copy the Production_Data_Converter.exe tool to the folder containing the PD_NVM0.s19 and 
PD_NVM1.s19 files. Execute the Production_Data_Converter.exe. This can be done by either 
clicking on the Production_Data_Converter.exe or opening a Command Prompt window and 
running the executable at the command line. The output is a PD_NVM.s19 file containing the 
production data from the active NVM sector. The command line version is shown in Figure 3-16.

NOTE
The Production_Data_Converter.exe tool can be found in the 13193EVK in 
the following folder: 
\source\Zigbee_EVK\EVK_Common\CPROG_Tool\Scripts\
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Figure 3-16. Command Window

10. Under the File menu, click on Load Application to open the Load Executable File window as 
shown in Figure 3-17. Select Freescale S-Record (*.s19) using the Files of type: drop down menu. 
Navigate to the folder where the Embedded Bootloader.s19 file is located. Select the file and click 
the Open button.

Figure 3-17. Load Executable File Window

The Embedded Bootloader is now programmed to the PCB as shown in Figure 3-18.
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Figure 3-18. Status Window

11. Write the NVM production data back by selecting the PEDebug menu. Then select Programming 
Options and Start Expert Mode Programmer. Select SS Specify S-record and locate the PD_NVM.s19 
file built in Step 9. Select the PM Program Module option and production data is written to flash.

12. Remove power and disconnect the BDM cable from the PCB. Next, power up the PCB. The PCB 
is now ready to upload an application. This is indicated by all four LEDs being on. See Chapter 2 
for more information about how to upload an application.

NOTE
The applications must have the production section in the NVM cleared. That 
is, the application image must contain 0xFF’s in the production data section 
of the NVM.

For addition information, see the 802.15.4/ZigBee Embedded Bootloader 
Reference Manual (802154EBRM) available at www.freescale.com/zigbee 
or on the BeeKit CD.
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Chapter 4   
Evaluation Kit Demonstration Applications
The sample applications provided with the BeeKit CD are based on Freescale's Simple MAC (SMAC) 
and/or the 802.15.4 MAC software. For ZigBee stack application examples, see the appropriate Freescale 
BeeStack documentation.

The following applications are included on the BeeKit CD:

4.1 SMAC Applications
The following list highlights currently available SMAC applications. Refer to the Simple Media Access 
Controller (SMAC) User’s Guide and AN3231 for more information.

• Basic Packet Error Rate (PER)

• Wireless UART

• Accelerometer

• Range

• Lighting

• Test Mode

• Repeater

• Simple Protocol Test Client

• Over the Air Programmer (OTAP)

4.2 802.15.4 MAC/PHY Applications
The following list highlights currently available 802.15.4 MAC/PHY applications. Refer to the 802.15.4 
MAC/PHY Software Reference Manual (802154MPSRM) and other appropriate Freescale documentation 
for more information.

— PTC Demonstration (AN2771)

— 802.15.4 MyStarNetwork Demo (802.15.4 MyStarNetwork User’s Guide)

— 802.15.4 MyWirelessApp Demo (802.15.4 MyWirelessApp User’s Guide)
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4.3 Windows Based Application
The following list highlights currently available Windows based applications. Refer to the Embedded 
Bootloader Reference Manual (802154EBRM), the Freescale Test Tool Online Help, and other 
appropriate Freescale documentation for more information.

— Test Tool

— Command Console

— Script Server

— Embedded Bootloader

— Radio Test
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Chapter 5   
Solution Development
This chapter shows users how to begin development of an MC13192 system solution. Each section 
highlights the documentation users must read before they begin system development. 

Unless specifically stated, all documents described in this chapter are available at: 
www.freescale.com\ZigBee 

5.1 Hardware Design and Layout
Before users begin their hardware design and layout, Freescale provides and recommends reading the 
documents shown in Hardware Design and Layout Recommended Reading These documents contain 
reference design information and hardware design guidelines.

In addition to this, a complete reference design package can be provided upon request. 

Table 5-1. Hardware Design and Layout Recommended Reading

Document Title Part Number

Compact Integrated Antennas:Designs and Applications for the MC13191/92. AN2731

Accelerometer Demonstration With the Sensor Applications Reference Design (SARD) AN3232

Simple Media Access Controller (SMAC) User’s Guide SMACRM

13192EVB Evaluation Board Reference Manual 13192EVBRM

MC13191 2.4 GHz, Low Power Transceiver Reference Manual MC13191RM

MC13192/MC13193 2.4 GHz, Low Power Transceiver Reference Manual MC13192RM

MC13191 2.4 GHz, Low Power Transceiver, Data Sheet MC13191DS

MC13192/MC13193 2.4 GHz, Low Power Transceiver Data Sheet MC13192DS

http://www.freescale.com\ZigBee
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5.2 Software Applications Development
When building applications for the MC13192 transceiver, Freescale recommends using the Codewarrior 
Software Development Tools. A trial version is shipped as part of the 13193EVK. For complete 
documentation and help, see the Metrowerks homepage at www.metrowerks.com. 

In addition, Freescale provides and recommends reading the documents shown in Software Applications 
Recommended Reading  Most notably, Freescale recommends reading the documentation that describes 
the Embedded Bootloader implementation and the Non-volatile Memory (NVM) area used for storing 
information in the application.

5.2.1 Proprietary Applications (SMAC)
To begin development of a proprietary application, Freescale provides and recommends reading the 
documents shown in Table 5-3.

Table 5-2. Software Applications Recommended Reading

Document Title Part Number

Handling MAC Address Erasure, Recommendations for Restoration AN2825

802.15.4/Zigbee Embedded Bootloader Reference Manual 802154EBRM

MC13191 2.4 GHz, Low Power Transceiver, Reference Manual MC13191RM

MC13192/MC13193 2.4 GHz, Low Power Transceiver, Reference Manual MC13192RM

HCS08 Flash Library Integration For Zigbee and 802.15.4 Applications AN2770

Table 5-3. Proprietary Applications Recommended Reading

Document Title Part Number

Demonstration Operation: Running the Packet Error Rate, Wireless 
UART, Accelerometer, Range, and Lighting Demonstration Applications

AN3231

MC1319x Accelerometer Demonstration Program: Quick Start Guide AN2762

Sensor Applications Reference Design (SARD) User’s Guide MC13192SARDUG

Simple Media Access Controller (SMAC) User’s Guide SMACRM

http://www.metrowerks.com
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5.2.2 802.15.4 Specific Applications 
Freescale provides and recommends reading the relevant Freescale 802.15.4 MAC documents. These 
documents will help guide users through development of an application that sits on top of the 802.15.4 
MAC.

5.2.3 ZigBee Applications
For development of ZigBee applications, refer to the appropriate BeeStack documentation. 

Table 5-4. 802.15.4 Specific Applications Recommended Reading

Document Title Part Number

802.15.4 MAC/PHY Software Reference Manual 802154MPSRM

Zigbee/802.15.4 PHY Protocol Test Client (PTC), 
Running the PTC Demonstration on the 13192-EVB (DIG-528 board)

AN2771

802.15.4 PHY (Physical Layer) Setup and Porting to Various Printed Circuit Boards (PCBs) AN2769
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Chapter 6   
Test Tool Utility
This section introduces the Freescale Test Tool Utility’s features, basic components, and setup 
configuration. The Test Tool is a Windows based graphical user interface that communicates via the PTC 
test interface to the Embedded Bootloader enabled applications that run on the 13192-EVBs. The Test 
Tool provides the following applets:

• Embedded Bootloader

• Command Console

• Script Server

• Radio Test

NOTE
The Command Console and Script Server require users to have knowledge 
of the 802.15.4 standard. See the 802.15.4 Standard from the IEEE group 
for detailed information about the 802.15.4 specification. Visit 
www.ieee.org for more information.

The following sections cover each of the Test Tool utilities in more detail.

6.1 13192-EVB Setup for USB Operation (Test Tool Utilities)
To setup the 13192-EVB for USB operation, perform the following steps.

1. Plug the 13192-EVB into a USB port of the PC with the supplied USB cable.

2. Switch the EVB power switch (S106) to USB.

3. Follow the Windows Hardware Manager default options during the driver install.

4. After the install is complete, reboot the system.

NOTE
In some cases it may be necessary to manually locate the drivers. To do so, 
perform the following steps.

5. Reinsert the Evaluation Kit CD.

6. If prompted for the ftdibus.sys driver, select Browse and change to the drivers directory on the 
BeeKit CD. Reinsert the BeeKit CD and click on the OK button.

7. If prompted for the ftser2k.sys driver, select Browse and change to the drivers directory on the 
BeeKit CD. Reinsert the BeeKit CD and click on the OK button.

8. After installation is complete, reboot the system.

http://www.ieee.org
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6.2 Command Console
The Command Console allows users to interact with the hardware and send 802.15.4 commands directly 
to the 13192-EVBs. The interface is similar to that of an AT terminal application. 

NOTE
The Command Console interface requires users to have a working 
knowledge of the 802.15.4 specification and command set.

The Command Console makes it possible to send commands from a computer to a device as well as receive 
responses from a device.   

This section describes the following elements of the command console:

• Command Console Main Window Overview

• Common Function Overview

For additional details on the Command Console, refer to Command Console help by clicking on 
Start->Programs->Freescale Zigbee->Test Tool->Help.

Figure 6-1 shows the Command Console main window. The following describes the basic functionality.

Figure 6-1. Command Console Main Window
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6.2.1 Command Console Basic Functionality
This section provides step-by-step instructions for the Command Console. This will help users understand 
its basic functionality.

The PTC application is loaded by default on the 13192-EVBs. If the boards have been flashed with another 
application, run the Embedded Bootloader Utility and flash the board with the PTC Application. If the PTC 
application is running on the board, all four LEDs will light when the board is powered on.

If users have attached the 13192-EVB they will need to add the device to the Communication Setting 
option under the Tools menu. The USB driver for the 13192-EVB maps the board to a COM port. To 
determine the proper COM port for the USB driver, run the Windows Device Manager and check the COM 
ports to determine which port is mapped to the USB driver.

6.2.2 Running the Command Console
1. Start the Test Tool Application as previously described, then launch the Command Console 

application by clicking on View->Command Console as shown in Figure 6-2.

Figure 6-2.  Test Tool Window (Command Console Select)

2. Select the device COM port and click the OK button as shown in Figure 6-3.
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Figure 6-3.  Test Tool Window (Command Console Device Select)

The Command Console window appears as shown in Figure 6-4.

Figure 6-4.  Command Console Window

3. In the Enter Command field, type MAC. This field is located at the bottom of the Command 
Console window.
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The first field of the Status bar changes (The status field is below the Enter Command field). It now 
displays the first available command with the prefix MAC. The Command Console offers command 
completion. This means users do not have to enter the whole command name. To complete a command, 
press <Ctrl> + <Space>. Press <Ctrl> + <Space> again and a pop-up menu appears displaying all the 
commands available starting with the MAC prefix.

If an ambiguous command is entered, a pop-up menu appears showing all available commands beginning 
with the string present in the input field as shown in Figure 6-5.

4. From the pop-up menu in the Command Console window, click on the MacPurge.Request button.

Figure 6-5. Command Console (MAC Command Entries)

As shown in Figure 6-6, sub-sequent fields of the Status bar now display the parameter selected in the 
current command. In this case, the command is MACPurge.Request and the parameter is msduHandle with 
a value of 0x55. The right-most status field provides a description of the command.
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Figure 6-6. Command Console (MACPurge.Request Command)

5. Send the command by pressing the Enter key or clicking the Send button.

The Rx/Tx view is now updated with the command that was just transmitted (MacPurge.Request). The 
device promptly responds with an event. The most recent item is always placed at the bottom of the list. 
A more detailed view of each command or event can be seen by expanding the line by clicking on the [+] 
symbol. In this example, the MacPurge.Request is expanded by clicking on the [+] symbol in the display 
area. The information appears as shown in Figure 6-7.
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Figure 6-7.  Command Console (Expanded Command View)

6.3 Script Server
The Script Server manages Scripts and Test Sets. The server is able to load and execute one or more Scripts 
and Test Sets. Output for the Scripts can be displayed. The Script execution progress and the test results 
are displayed in a separate view. The output and results can be stored in text files. One or more Scripts can 
be added to and saved as a Test Set. A Test Set can include other Test Sets. As an extended feature, the 
Test Results can be sent as an e-mail message.

NOTE
See the Script Server Guide by clicking on Start->Programs->Freescale 
Zigbee->Documentation->User Guide for more details.

The following steps describe how to get started with the Script Server.

1. Launch the Script Server application from the Test Tool main window toolbar by clicking on 
View->Script Server. The Script Server window appears as shown in Figure 6-8.
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Figure 6-8.  Script Server Window

2. Click on the F1:Add button or press F1 to search for Scripts and Test Sets. Perform a normal 
windows browse session to find the desired files. The demo scripts delivered for the Evaluation Kit 
are located in the following folder: 
C:\Program Files\Freescale\Test Tool\Scripts\ZigBee\Demoscripts.

The Scripts are executed by loading () and executing the following script:
ZigBee_Demo_Run.py

This file is located in the following folder:
C:\Program Files\Freescale\Test Tool\Scripts

The basic script functionality is as follows: 

• ZigBee_Demo_Associate

— Uses two devices

— Coordinator starts PAN network

— Device associates to the Coordinator 

• ZigBee_Demo_Data

— Uses two devices

— Coordinator starts PAN network

— Device associates to the Coordinator 

— Device sends direct data

— Device receives indirect data from coordinator

• ZigBee_Demo_GetSet

— Uses one device

— Sets and gets all PIN attributes. 

• ZigBee_Demo_Scan
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— Uses one devices

— Performing active scan

— Performing passive scan

— Performing energy detection

— Performing orphan scan

• ZigBee_Demo_Start

— Uses two devices

— Coordinator starts PAN network

— Device performing scan

3.  Select one or more Scripts (file extension is py) or Test Sets (file extension is tst) and click the 
Open button.

For example, as shown in Figure 6-9, the RadioTest.py file was selected from the RadioTest folder.

Figure 6-9.  Test Case/Test Set Search Window

4. As shown in Figure 6-10, from the Script Server window, highlight the RadioTest.py file and click 
on the F3: Execute button to start the selected Scripts/Test Set.
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Figure 6-10. Script Server Window (Run Scripts/Test Sets)

The first two lines in the Script Output view are always as follows.

10:00:59 Default Pythin Script executed ! 
10:00:59 SearchPath included !

5. The Script can be terminated normally or can be stopped by clicking on the Stop Execution button 
in the Script Server window as shown in Figure 6-11.

Figure 6-11. Script Server Window (Stop Execution)
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The progress and result output are displayed in Test Results window as shown in Figure 6-12.

Figure 6-12.  Test Results Window

6.4 Radio Test
The Radio Test window, as shown in Figure 6-13, runs the radio test script dialog using one board for radio 
testing or two boards for sending data between the boards. The application picks the first boards from the 
List of Devices. If the devices are not connected, then change the order in communication settings by using 
the Communication Settings option in the Tools menu. Highlight the device and use the Move Up or Move 
Down button to change the order.

The Radio Test Script has two parts:

1. Radio testing

2. Packet Error Rate (PER) estimation 

The PER must be below 1% sending packets with 20 bytes payload to meet the 802.15.4 specification.
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Figure 6-13. Radio Test Window

3. To launch the Radio Test script, from the Test Tool main window toolbar, click on View->ZigBee 
Radio Test as shown in Figure 6-14.

Figure 6-14.  Test Tool Window (ZigBee Radio Test Selection)

NOTE
See the ZigBee Radio Test Guide located in windows by clicking on 
Start->Programs->Freescale Zigbee->Documentation->User Guides for 
more details.
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